MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

two issues with FH-2 (protection glass and USB-C connection)
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author two issues with FH-2 (protection glass and USB-C connection)
red
I bought a new FH-2... two issues (one solved)

1) the protection glass was not glued correctly at the front plate - was only fixed at one side. This was a nice fiddly job to glue it in position...
Batch 20181211 (4) ... maybe you will check this for further batches

2) No connection with my 2018 iMac... What exactly is the right USB-C cable? The price range of offered cables goes from $3.00 to $50.00... Mine was $6.00

Any advice?

Thanks
bigben54
Hi, first post so can't open a new topic yet but both are related to this a bit.

I'm just getting in to my FH-2 (v1.5 firmware) and two issues...

1. Connection to host. I'm unable to either get the configuration tool working completely, or receive MIDI from DAW.

First attempt was from workstation Mac, which is on other end of room. Using an active USB3 repeater cable and a powered USB3 hub, I am able to connect to other USB devices from the Mac, and when I plug in the FH-2 to the hub the C icon comes up.

I can also see it as a device in Live and Audio MIDI Setup app. So far so good.

I open the configuration tool from local html file as advised, in latest Chrome, allow MIDI when prompted and the FH-2 is automatically selected for input/output. Web MIDI status shows OK. Great!

But I'm never able to actually get anything from it and doesn't appear to receive anything on C. The Send Msg button doesn't show anything on FH-2 screen. The Request FH-2 Version button only makes the request but never gets any output in right status box. Same with Upload from FH-2 button.

Also tried sending it MIDI from Live, but it's not receiving even though I can select it as an output.

Thinking my long cable and hub in between the Mac and module was issue, I went through all the same stuff with a Mac laptop connected directly to it via 3ft USB-C cable. Identical results.

I am able to use the module as a host with a controller. The A port works and messages are flying.

2. I somehow managed to push on the displays protective glass and split it in two. Screen is fine... but have a lead on where I could get a replacement?

Thank you!

Ben
bigben54
red wrote:
I bought a new FH-2... two issues (one solved)
2) No connection with my 2018 iMac... What exactly is the right USB-C cable? The price range of offered cables goes from $3.00 to $50.00... Mine was $6.00

Any advice?
Any


I'm not fully working myself, but in terms of cabling I can say the first one I bought (USB-C to USB-A) turned out to be for power *only*. It was nice looking and well rated on Amazon but didn't read fine print that it's just for fast charge of devices and not data at all. It wouldn't connect the FH-2 at all.

I then got an Anker one that seems to do data without issue elsewhere but still having issues with FH-2 as above.

The number and type of cables with the USB-C connector (also used for Thunderbolt3) is insane.
red
the secret behind cheap USB-C cables ...




... two wires are not enough!
os
eek!
os
For reference, here are some cables known to work:

https://www.amazon.co.uk/dp/B019DRKWU8/ref=cm_sw_em_r_mt_dp_U_1vytCb3Q 0FWB1

https://www.ebay.de/i/263995877968?chn=ps
red
Thanks



Found a working one locally (10 $) - so everything is OK!


cool
auxren
Not all USB-C cables are created equally. Also, long cables need to have active electronics inside to be able to pass the data over the longer length.
If you have one of the newer USB-C Apple MacBooks, the cable in box that you use to charge your computer does not pass data.
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group