MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Odd timing for sync pulse on trigger outputs: uniPulse
MUFF WIGGLER Forum Index -> Tubbutec  
Author Odd timing for sync pulse on trigger outputs: uniPulse
jlo
I'm testing the sync pulse on the uniPulse trigger output 1 and I think I'm seeing timing issues.

48 PPQN configured => no pulses output
24 PPQN configured => OK
16 PPQN configured => 8 PPQN output
12 PPQN configured => 24 PPQN output
8 PPQN configured => OK
6 PPQN configured => 12 PPQN output
4 PPQN configured => 8 PPQN output
3 PPQN configured => 6 PPQN output
2 PPQN configured => 4 PPQN output
other configurations not tested

Can you confirm?
tubbutec
No, can not confirm.

Just tested (again) all PPQN settings with various midi clock speeds.
Which program are you using to send the midi clock?
How did you test for the correctness of the settings? oscilloscope? Or do you verify with a drum machine? In the latter case I can imagine a drum machine might skip clock pulses in certain conditions..
jlo
I am sending MIDI clock from Cubase AI 6 and looking at the uniPulse outputs on an oscilloscope. On oscilloscope ch 1 I'm monitoring and triggering on D1 and on ch2 I'm monitoring P1. Neither output is loaded (except for the scope probe). D1 is configured as Sync Clock and P1 as Sync Pulse. I select the same PPQN for both, upload it, start the MIDI clock, and compare upper and lower traces. D1 is correct for all the PPQN I've tested, but P1 is behaving as I documented above.
jlo
Here is an example configuration:



And here is my scope snapshot of the uniPulse outputs D1 and P1 when driven by Cubase running at 60 bpm. The upper trace is D1 and the lower is P1. 1/12 ~= 0.083 and that's what the upper trace shows as the period, but the lower trace shows pulses on every D1 transition, i.e. 24 PPQN.

tubbutec
Ok, can confirm this. Was only looking at the digital outputs when I tested this.
Will fix this and post an update..
tubbutec
You have mail with an uniPulse update for testing
csiprophet
Hello Tubbutec, I see that some more development is currently going, great thing ! Any chance that you could also fix the 66 arp issue in up/down mode that has been reported a few months ago ? The 66 community will thank you !

I could test this if needed Rockin' Banana!
MUFF WIGGLER Forum Index -> Tubbutec  
Page 1 of 1
Powered by phpBB © phpBB Group