MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

DDSR output failure (1st run of DDSRs only)
MUFF WIGGLER Forum Index -> BugBrand Devices  
Author DDSR output failure (1st run of DDSRs only)
BugBrand
I meant to post about this a while ago. A few people have had to return their 1st run DDSRs due to one or more gate outputs stopping working (LED still shows) - enough failures to give me some worries! It is an easy enough fix for me - replace transistors - but means a return to base, so not ideal.

This is due to me stupidly leaving off a resistor on each output - just ordered 2nd run of DDSRs and have modified to include this. I can also manage to add this on to original DDSRs without too much trouble, though I didn't on the first few repairs as I hadn't at that point realised.

Suffice to say - your original DDSR gate outputs won't necessarily die (my 2 still work fine for example) but if they do I can easily sort the repair. User reports have suggested that outputs have failed just in normal use / out of the blue so something to be aware of.
chrisdermo
Oh no! Good to know, mine still works fine too.
sungja
My ddsr is working fine but when or if it fails i let you know Tom.

How many people have had this problem? Is it reasonable to think it will fail eventualy sooner or later??
BugBrand
I think 3 or 4 (out of initial run of 40).
sungja
I am not worried..
T. Jervell
We’ll I’m one of the people who had to send it back, and I’m sure the output failed when I managed to patch an output of my SQ-1 to the output of the DDSR d'oh!
So user error in my case, got to pay better attention to my ins and outs I guess hihi
sungja
Its easy to do this sometimes when patching in late hours or getting to excited. I have done similar patching errors before and will probably do it again. Luckily i have noticed these mistakes seconds later and pulled the plug before frying anything. hihi
sungja
I am taking my ddsr out of the frame any day now so thinking of maybe putting those resistors on the gate outputs myself.
Any guide as to how Tom? Resistor values?
DickMarker
Happened to me, can't pinpoint exactly why - Tom fixed it up super quick.
BugBrand
sungja wrote:
I am taking my ddsr out of the frame any day now so thinking of maybe putting those resistors on the gate outputs myself.
Any guide as to how Tom? Resistor values?


It is a bit fiddly - depends on your skills.
I have to do one of mine in the next few days so will see if I can snap some pics. But it involves i) cutting small traces & ii) working with 0805 size resistors (470ohm is ideal)
sungja
Ok i was thinking adding a few resistors between the pcb and banana jacks would do it but if it involves cutting traces i am not the man for the job. hihi

I will offcourse take a look at pictures when they are up.
phisynth
well, it looks like my first gate output just died Dead Banana
MUFF WIGGLER Forum Index -> BugBrand Devices  
Page 1 of 1
Powered by phpBB © phpBB Group