Dwarfcraft Super Wizard Insert

A place for the string slingers, pedal freaks and amp snobs in our midst.

Moderators: luketeaford, Joe., lisa, Kent

Post Reply
c0ntr4d1ct10n
Common Wiggler
Posts: 239
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Dwarfcraft Super Wizard Insert

Post by c0ntr4d1ct10n » Thu Mar 14, 2019 8:55 am

Does anyone know how to use the insert input on this pedal? I have only seen demos of the Minivan using the insert.

You are supposed to be able to feed another pedal's effect by connecting a stereo out from the insert with a mono ring jack into the input of the other pedal and tip jack into the output of that other pedal.

I have done this with a TRS to dual mono (one is TS and the other is RS) but get no results.

User avatar
yarderyyz
Learning to Wiggle
Posts: 14
Joined: Thu Dec 14, 2017 3:18 am
Location: Vancouver

Post by yarderyyz » Thu Mar 14, 2019 7:54 pm

I've done what you described with mine and had no problem. Is it possible you flipped the input and the output on the pedal you are trying to connect in the loop?

c0ntr4d1ct10n
Common Wiggler
Posts: 239
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Fri Mar 15, 2019 9:00 am

yarderyyz wrote:I've done what you described with mine and had no problem. Is it possible you flipped the input and the output on the pedal you are trying to connect in the loop?
I'm plugging the RS into the input and the TS into the output. I have tried the other way but it makes no difference. However, when I use a stereo TRS to dual TS cable, i get weird results - the other pedal's fx does run through and it gets wild, but it seems to run independent of the feedback.

c0ntr4d1ct10n
Common Wiggler
Posts: 239
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Fri Mar 15, 2019 11:58 am

So it turns out that i had a short in the ring jack so when I fixed that up it works now. However, i am mostly getting a lot of self oscillation in mutate mode - is that just the function of mutate mode? I only recently just got this pedal.

c0ntr4d1ct10n
Common Wiggler
Posts: 239
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Fri Mar 15, 2019 10:27 pm

So ive worked out that any pedal i hook up to the insert holds a constant effect without me even playing, and I believe this is due to the noise of the Super Wizard going through the effect loop. This can't be right can it?

c0ntr4d1ct10n
Common Wiggler
Posts: 239
Joined: Mon Aug 13, 2018 9:02 am
Location: Australia

Post by c0ntr4d1ct10n » Fri Mar 15, 2019 11:34 pm

Another thing i noticed happens is only the line noise seems to be processed by the external effects and any signal input into the super wizard doesnt go through the external effects loop via the insert.

Post Reply

Return to “Guitars, Basses, Amps & FX”