MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

FH-2: MIDI control over LFO rate broken?
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author FH-2: MIDI control over LFO rate broken?
saiteron
ok so this time i did my homework before posting and double-checked the forum as well as the manual and still can't find a solution, so here goes:

i'm trying to use the FH-2 + FHX-CV8 expander with my MIDI controller (Midi Fighter Twister) to basically have a set of 8 LFOs with 4 MIDI-controlled parameters apiece. i currently have one CC mapped to direct output, one to LFO rate, one to sine level and one to random level. all work just fine except for the LFO rate mapping. i took a little video to show what i mean (viewable here; apologies for the sideways/shakiness):

https://photos.app.goo.gl/aaRBgVq1ZvDq1N8EA

i have tried working around the problem in a variety of ways:
- different MIDI channel
- different MIDI CC
- different outputs (both on FH-2 and on expander)
- different MIDI controller (tried OP-1 and Beatstep Pro)
- different LFO sync values (ranging from 0/32 to 1/16)

i just can't seem to be able to control the rate of the LFO via MIDI. very frustrating while it seems to be a hardware problem i'll definitely admit it could just be good old fashioned user error. anyone else encounter this issue/have a solution or workaround?
os
I just tested it and it's working fine for me. Can you upload your configuration (either a screenshot or better a SysEx dump)?
saiteron
so i think i discovered the issue/bug at work here.

when i use the FH-2 itself to program the MIDI CC mapping specifically to LFO rate, even though it shows as correct on the screen it does not map correctly. i have confirmed this by doing a SysEx dump from the FH-2 to the config tool after making multiple such mappings. when the dump completes, none of the LFO rate mappings appear in the config tool.

when i use the config tool to program the MIDI CC mappings to LFO rate, then do a SysEx dump to the FH-2 and save the configuration, the mappings work just fine. if i do a SysEx dump from the FH-2 back to the config tool, the mappings show up exactly as i programmed them.

in other words, it seems like something may be broken when mapping to LFO rate on the FH-2 interface itself. i encountered this issue because sometimes i manually remap my controller(s) on the fly or when i'm away from the computer but if i have computer access this should not be an issue. still, would be great to have this bug resolved if possible.

i will try to get some time to send some pics/vids of this bug in action but i'm working all day today through Sunday so i'll have to wait til next week to get to it.
os
Thanks. I've fixed that for the next release.
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group