Help needed: one castle stopped working (edited)

home of post-70s electronics

Moderators: Kent, infradead, bartlebooth

Post Reply
arnoux
Super Deluxe Wiggler
Posts: 2038
Joined: Sun Oct 02, 2011 9:53 am
Location: Lisbon

Help needed: one castle stopped working (edited)

Post by arnoux » Sun Jun 09, 2019 4:08 pm

Hey people,

bad surprise tonight while trying to trigger my Serge from the Quantussy, just discovered one of the grey outs do not output voltages. I'm sure it always worked flawlessly.

:sadbanana:

No diy skills, but I may find someone that can help if it's an easy fix like resoldering a joint. Is it easy to open to inspect removing the screws? Screws to wood always scared me.




Edited: for better explanation

The Grump
Veteran Wiggler
Posts: 515
Joined: Fri Apr 15, 2016 6:17 pm

Post by The Grump » Mon Jun 10, 2019 10:09 pm

I have noticed that the outputs from the Castles (grey) are quite a bit lower than the triangle outputs, especially when squishing. I'm not much of a repair wizard either, but i do know how to spot problems, and I'd suggest getting an oscilloscope if you don't already have one, and monitor/measure the outputs of your Coco. You'll learn a ton. It may not be malfunctioning, but just that your serge needs more juice than the Coco can throw from that output.

arnoux
Super Deluxe Wiggler
Posts: 2038
Joined: Sun Oct 02, 2011 9:53 am
Location: Lisbon

Post by arnoux » Tue Jun 11, 2019 5:08 am

The Grump many thanks for your reply, unfortunately I'm pretty sure it is not working: at audio rate, in the Coco itself, do not output audio signal at all, at LFO rate I see it has no effect.

How is it made inside?
Is the banana jack connected directly to the PCB or there's some wiring? I'm not able to make diagnostics but if it's a simple joint that failed I may be able to fix it with the help of a friend.
And what about opening it? Is it safe to DIY or better send it back?

ClausF
Wiggling with Experience
Posts: 449
Joined: Mon Oct 08, 2012 12:01 pm
Location: Germany, FFM

Post by ClausF » Tue Jun 11, 2019 6:01 am

If it is only a faulty jack this should be easy, here's the thread for the same on a Plumbutter 2:
viewtopic.php?t=169993&highlight=

knows
Common Wiggler
Posts: 237
Joined: Tue Oct 01, 2013 11:12 pm
Location: Nebraska

Post by knows » Tue Jun 11, 2019 3:20 pm

The screws on the top of the ciat lonbarde instruments hold the top wood pieces and circuit board to the bottom wood. When you unscrew them it should come apart easy, with the circuit board held to the top via the bananas. The one giving you the problem probably became unsoldered, it is a easy fix to resolder, just look at the other joints and see how they are held. You might not even need more solder, just reflow what is there.

Definitely read and follow the advice in the link in the post above!

User avatar
Doublecoolbossman
Wiggling with Experience
Posts: 308
Joined: Thu Nov 19, 2015 4:54 pm
Location: Morgantown, WV

Post by Doublecoolbossman » Tue Jun 11, 2019 7:26 pm

Re: banana jacks, i'm always worried that twisting plugs as I pull out could potentially damage the connection to the board. I guess the nut could/should prevent this. Does anyone else share this concern, or is it superstitious behavior on my part?

Post Reply

Return to “Ciat-Lonbarde”