FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 

iProgram card not working with the 218e
MUFF WIGGLER Forum Index -> Buchla, EMS & Serge  
Author iProgram card not working with the 218e

the iprogram card works great with the 208.

As soon as I try to control the 218e with the keyboard within the app there is no response. It's as if the 218e is not communicating or receiving midi from the Program card.

I have tried connecting via wifi and cable, both ways I am able to connect but I am not able to control the 218e from within the app.

It's a brand new Busa easel, on the buchla website I saw that there is an update for the 218e in February, here is the description:

Version 30.9 fixes a scanning bug with key 11 on version 30.8
Version 30.8 Changed MIDI channel input from Omni response to Channel 1 response, saves configuration settings, and adds remote enable and software version reporting

Could that in any way shape or form be relevant?

It seems as if I have a similar problem: the keyboard within the iPad App has no effect (meaning also: it doesn't control pulse, pitch or pressure for 208), parameter changes and sending presets for 208 work well. Till now I don't have any clue what could be the reason behind (assumption: something with the i2c processing ...).

My 218e has firmware version 30.8; iProgram Card has firmware version 60.
Hi Sonic,

is your easel by chance a recent BUSA release? As mentioned, I just got mine a few weeks ago.

Two weeks ago I contacted Busa via webform and haven't received a reply. I have no other means of contacting them.

As I don't really use the card very often, (it came, cheaply bundled with my easel) it's really not that big of an issue but I would prefer things to be working as advertised. Then again, running midi from another app to the 218 would be killer!

Would you care to elaborate your assumption concerning i2c processing?
My Easel is not a recent BUSA Easel; I purchased it in the second half of last year, i.e. it's a BEMI Easel made/delivered by BUSA.

I also contacted BUSA via Web form and got some answers, but unfortunately without any help (maybe I expressed the issue not clear enough or posed too strange questions with too much details, but more or less the statements handled WiFi problems, which don't apply).

Also for me in practice the keyboard function of the App is not too important, because I use iProgram Card and App in order to memorize/store and exchange presets, which works, if you follow some rules (e.g. after storing a preset, close and reopen the App, otherwise, if you store a second preset immediately, the App mostly crashes ...).

Now to the reasons for my assumptions: I can exclude issues caused by the WiFi connection (it works for parameters and presets, and using USB shows the same results). With some probability I can also exclude a defect in my individual iProgram Card, because I tried another one exhibiting the same behavior. Furthermore I can see that my iProgram Card receives data when I touch the App's keyboard, because I see blinking characters ('&' ... didn't get an answer what the different characters mean, whether success or failure ...).

Therefore the issue must be after the iProgram Card: edge connector, connection to 218e, Firmware of iProgram Card and 218e ...

At least one person gave me the information that Firmware 60 of iProgram Card and 30.8 of 218e works for him. So let's also exclude a Firmware issue.

I inspected the board and edge connector and didn't find any broken line, and all known pins of the edge connector work (Aux Card, TooBox, OC Card ...)

Somewhere I've read that the App's keyboard works only together with the 218e (though not confirmed by BUSA).

By the way: if someone has a constellation where the App's keyboard works with 218e and doesn't work after disconnecting the 218e from 208, then this hypothesis would be proven.

Thus taking the hypothesis that the iProgram Card doesn't process the data stream from the App's keyboard by itself, it must be send somehow to the 218e and being processed there, transformed to pulse and pitch CVs. And the only protocol I know for this is i2c ...

So I suspect that maybe a cable connecting 208 and 218e is not plugged correctly ...
Somewhere on the forum there was a person whom sold their 218 and was surprised that he couldn't use the 218 from within the app after that. It would be awesome if you could utilise the iprogram card in that sense.

So the Toolbox works for you? (To me, thats like the single most important thing. Haven't purchased one yet.)

If I had to guess it is either a Firmware issue of the 218e or a connection issue between the 218e and 208.?

I still have not gotten a reply from Buchla. I also sent them a PM with a link to this thread.

Thanks for taking the time to reply Sonic.

Edit: Here the link for the thread that I mentioned:
The ToolBox doesn't need nor has any connection to the 218 and works fine on a standalone 208.
I use the iProgram Card a lot!!
It is always quirky & I never updated it.

What version firmware is on your iProgram Card?
ritchiedrums wrote:
I use the iProgram Card a lot!!
It is always quirky & I never updated it.

What version firmware is on your iProgram Card?

Version 60.

The Store that I purchased the Buchla from has contacted Buchla and a dialog has been started. If any solution is found, I will keep this thread updated.
MUFF WIGGLER Forum Index -> Buchla, EMS & Serge  
Page 1 of 1
Powered by phpBB © phpBB Group