MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

X0xb0x buzzing even when the sequencer is stopped
MUFF WIGGLER Forum Index -> Music Tech DIY Goto page 1, 2, 3  Next [all]
Author X0xb0x buzzing even when the sequencer is stopped
charkachak
Hi,

I have just finished helping a friend of mine building his X0xb0x and we can't get rid of a horrible persistent buzz which can also be heard when the the sequencer is stopped. This buzz (or hum) can be pitched if I turn the tune knob whereas the filter and cutoff do not seem to have any effects on this awful sound., So we thought the problem might come from the VCO. the buzz is present in the phone output and the main output as well.

So far, we have replaced Q27 and Q24, C33, C11, C31, D25 in the VCO, matched pair with beta transistors (C1 to C4), replaced Q32 checked and rechecked every resistors values in the VCO, every transistors orientations. We have also tried to take measures around the VCO but it's very hard to get voltages here. Next step is to replace Q25 (the test diode confirms that it works properly) Q26 (the voltages seem good so I'm not sure it will change anything.) We have also tried several Ba6110

Any help would be much appreciated smile

PS : sometimes when the X0x is powered up there is no buzz, the latter only appears when the sequencer is started, but other times the buzz appears immediately
guest
do you have an oscilloscope? what frequency is the buzz? does it sound like a square wave (buzz) or sinewave (hum)? is there any difference at the mixout versus the headphone out? do any of the different modes effect it (midi in, pattern play, random, etc)? does it change level with the volume knob? do you hear it at the filter output (you can check on the resonance pot)? are all of the powersupplies good (5.3, 5, 6, 12)? does selecting square or saw effect it? what if you only listen on headphones (no cable connections to any other equiptment)?
charkachak
Hello Guest. thanks for your help.

I have a really cheap oscilloscope, but I don't really know how to use it properly :(. What should I connect it to to see the buzz frequency? I also have a multimeter.

The buzz or hum (not sure of how to differienciate a buzz from a hum with my ears) is present at the headphone, whether it is connected to my mixing console or not. When I plug my headphone to the headphone output on the X0x the buzz seems louder here than in the mixout output. yet it is also audible there.

The buzz can be heard whatever the mod I choose (except for random, maybe, but I'm not totaly sure of it because it's hard to hear it with those crazy random mod sounds)

The volume pot acts on the level of the buzz. It only appears (at least it is audible)when the volume pot is one or two steps step after the middle of its course.

When I connect my distortion pedal the buzz is so awful behind the acidbassline that you have to lower the volume knob real down. I have tested with another I/O board (I have two other working Xoxen which only have white noise and the VCA clicks) but there is still buzz or hum.

Square or saw do not affect the buzz. My friend had checked the power voltages (they were all good.). Yet the X0x acts as it should (you can make acid with it but there is this persistent annoying buzz.)

How can I check if it's present at the filter output. And where is the filter output smile

since I can pitch it with the tune knob, is it necessary to have a look at the VCA? Can it be related to it or the env or the VCF (or the digital part) or only in the VCO section?

I've just recorded an audiosample of he buzz in wav format. Here's a link, maybe you will be able to tell me if it's buzz or hum:

https://wetransfer.com/downloads/dd689810c4c0522c566142e86df33c5b20190 814115229/2561e8d41a9b88b7e99bc19d8aed010620190814115229/23dc95
guest
does the buzz change pitch with the notes as well as the tune knob? for example, play a low note - listen to the buzz when note is finished playing, then play a high note and repeat. did the buzz track the frequency?

its likely something from the VCO coupling into the powersupply. put your scope on AC coupled, and put your probe on the 12V powersupply line. go down to 10mV/DIV and see if there is a low freqnency waveform present. next, take a look a the square and saw waves. these can be found on the waveform switch. then you can look at the output of the VCF, this can be found on the resonance pot (one of the legs will have the strongest signal).
guest
check that following resistors are the right values: 101, 105, 34, 35, 36, 45
charkachak
Hello Guest.

I haven't tried to scope what you suggested because I checked some voltages in the VCO section and I noticed something strange with J6 and IC11 (which is socketed.) When IC11 is on its socket I only get 0.6V on J6. When I remove it I get 5.25 or 5.30v. I have replace it with one of my working X0x but the voltages are the same.

I have checked the resistors you pointed me to but there were all right values.

When I play with different octaves your guess was good: the buzz tracks the frequency.

Do you think I need to scope around the VCO? or rather checked voltages and compared them with one of my working X0xen (do I need to plug everything to test voltages? or only J4)

With everything plugged I noticed that D30 and D31 only get 2.346V and it's the same on J6 and TM5.
guest
D30,31 and U11 are part of the CV generator circuit, so 2.3V is within range of what the CV should be (1-5V). the issue is most likely aroud Q24,25,27 or some capacitive coupling that isnt readily apparent. the issue is, as the capacitor resets in the VCO, too much power is being drawn, and the powersupply has spikes on it. these spikes couple into the rest of the circuitry and create the sound. the only way to track this down, is to figure out how these spikes are coupling in. the powersupply is my mian guess, but it might be something else. so you need to scope to find out where the signal is getting injected into the audio path (VCF,VCA?) and how its getting injected (throuhg powersupply, through some stray wire?). to do this, you scope the powersupply and the various stage outputs to see where the spikes are present. the spikes will be very short in duration, so you might have set up the scope for normal trigger mode to see them.
charkachak
Thanks, I'll try to scope the different outputs in the audio path and see if I find something. Do you think Q26 could also be the culprit? I have other 2sc1583s.
Where should I probe for the VCA and the envelope?
How can I check is the issue isn't related to stray wires?
guest
the VCA can be tested on the volume pot. the envelope is unlikely, so lets hold off on that for now. and im not sure about the stray wires issue at the moment either, thats sort of a long shot. make sure C31,32 are soldered in correctly.

if you have a second working x0xb0x, you can disconnect the ioboard from one, and plug it into the other, and see if the problem persists.
charkachak
I've already tried with another I/O board from one of my X0x and I get the same buzz.

I have scoped the 12V rail at j4 and the scope did not get anything, same thing at J4 for the 5.33V.

On the waveform switch (with 10mV/div I got a waverform I couldn't properly see and if I change to 5V/Div I get the saw and the square waveshape

From the reso pot I got a kind of fuzzy sawtooth that couldn't be seen on my Chinese scope with 10mV/div.

I'll have a look at the volume pot.

Can this buzz come from a broken pot? Or a bad tune pot? or maybe a mistake from my friend if he installed installed a linear pot instead of a log one?
guest
its most likely an electorlytic cap with a cold solder joint someplace. the spike you are seeing is when the VCO integrator cap resets. for a very short period of time, a lot of current is drawn from the 12V rail to refill the capacitor. this is spike in current is somehow finding its way to the output.

what you can do to see things better on your scope, is to set one channel to normal trigger mode, and connect it to the output. this will set the scope to trigger on the spikes. they are quite large and make for a good trigger signal. then, probe around various places on the board with a second scope probe. this will keep the second probe in phase with the noise, and you can see if the spikes also appear on your signals in those other areas.

you can also narrow things down by disconnecting various sections. for example, if you lift one side of R62, you take the VCO out of the audio pathway. is the sound still there? if yes, then take the VCF out by lifting one leg of R121,122. is the sound still there? if yes, then take the VCA out by lifting one lef or R155. is the sound still there? if yes, then the problem is in the mixer stage.
charkachak
Of course, I chose to narrow things down and the buzz seems to come from the VCA because when I lifted one leg of r155, the buzz was gone and I got the 303 white noise smile.

Any ideas where to look first in the VCA? Maybe I'll try to replace all the capacitors (because my friend had a very sharp clik at first which was due to a defective capacitor in the envelope.)

Many thanks again, you rock man thumbs up
guest
i just want to verify: when you had R121,122 lifted (but not R155) you still heard the noise?

in this case, check that C40,37 are well soldered.

re-attch R155, but not R121,122. lift one leg of R120, is there still noise? if yes, lift one leg of R131, is there still noise?

are you using BA6110 or BA662? if BA662, is it one of the clones? is the VCA chip socketted?
charkachak
When I had R121,122 lifted (but not R155) I still heard the noise (yet r62 was resoldered.)

In fact, I proceeded as you suggested me. I first lifted one leg of R62 (I could hear the buzz), then I resoldered R62 and lifted one leg of r121 and r122 (I still heard the buzz.) When I lifted r155, I ddin't hear the buzz anymore (but I wondered a bit later if I could hear it without the VCA?)

I'll check what you pointed me to (I have already changed all the caps in the mixer section, so and I'll lift some more legs.

On my friend's x0x there is a ba6110 (that's why we have tried to change Q1 to Q4 with matched 733's and 536's to see if the HFE had something to do with all this noise : it didn't change anything, at least it wasn't audible)

the ba6110 is socketed but for further tests (if you think it can help), I also have a Ba662 clown (one of yours apparently smile) with a trimmer.
charkachak
To be quite sure I have replaced c40 (which only reads 6uf on my meter) and C37 (with a new one even if I measured the right value.)

Then I lifted the legs you mentionned but there was still this buzz. So I investigated around the BA6110 and I noticed that when I bent pin 8 or 7 (which are part of the buffer according to the datasheet, the buzz disappeared) I desoldered C38, replaced it with a new one and also changed the caps around it (C56,C58 and C59.) but I still had buzz when the BA6110 is fully inserted in its socket.

Finally, since I have 17x BA6110s at home I inserted them one after the other and tested them.

Only one of the seventeen produced a very low buzz ! The other ones produced that awful buzz. it seems weird that 16 of the BA6110s have an issue (I'll test them later in one of my woking x0xen.)

With the BA6110 producing the weaker buzz I resodered all the resistors and gave it a try.

Without distortion I only heard the buzz if i cranked up all the volumes on my mixing console and on the X0x.

Yet, with distortion, I can still heard this buzz :( but it was less awful than before.)

Do you think the buzz is caused by the the BA6110? or a cold joint on the socked? (I have already reheated and reflowed many joints that looked suspicious.) even there. Should I replace the socket? (I have tested it for continuity from bottom to top of the PCB and didn't find anything.)
guest
it might be a bad B6110, but that doesnt seem likely. swapping out with a known good one from a working x0x is the best way to test. another test you can do, is to remove the BA6110, and very gently bend pin6 out of the way and then reinsert it so pin6 is not in the circuit. if it still makes the buzz, then it is a problem either with the buffer on the BA6110, or with some sort of pickup being generated near C40.

when you said the noise went away when you bent pins7,8, what were you doing? how were you only bending those pins and not all the rest? what are the voltages on pins6,7,8,9 of the BA6110?

also, there might be a bad trace somewhere. if you shut the power off, and measure the resistance from C40 -pin to ground elsewhere on the board, does it read 0ohm? and same with the +pin of C40 to r129, does that read 0ohm?
charkachak
I've already swapped the BA6110 of my working x0xen and still got the buzz. I've just tried five of my sixteen BA6110 that produced buzz in my friend's X0xb0x and I dont hear it in my working x0xen.

In fact, I noticed that when I removed C38, the buzz disappeared, so I checked where it was connected to and it was connected to the buffer on the BA6110 so I bent pin 8 and inserted the other pins on the socket (but there was maybe no buzz because the BA6110 was not fully inserted and did not produce any sound.) Then, I did the same with pin 7 and noticed there was no buzz also, but maybe again the BA6110 wasn't working properly with this pin bent.)

With the BA6110 inserted in its socket :

pin 6 5.28V
pin 7 5.28V
pin 8 5.35V
pin9 11.83V

Without BA6110
pin 6 5.31V
pin 7 5.32V
pin8 (when I put the meter in it I heard a buzzing sound and it started reading 1V then it dropped to 350mV. i tried to measure it again and it started around 750mV and dropped down to 350mV)
Pin 9 11.85V

my meter reads 0 ohm with c40 (- and ground) and c40+ and R129
guest
did you try it with pin6 not inserted? i suspect it will just buzz.

its odd that you heard the buzz with no BA6110 installed, and just the meter touching. what if you remove the BA6110 and put a resistor between pin8 and ground (maybe 100k)? does it buzz?

its possible that the 12V rail is coupling into the BA6110 via a short in the trace some place. follow the 12V trace from pin9 under R127,128 and use a sharp tool to scrape between the trace and nearby components.

another thing to try is to insert a capacitor between 12V and ground right next to the BA6110. you can use the pads on the BA662 slot for this. its possible there is extra noise on the 12V line or ground (due to something not right in the VCO) and some extra capacitance might stabilie it. sort of a band-aid, but might give useful information on where the problem is coming from.
charkachak
if pin 6 isn't inserted I get no buzz smile but the sound is kind of muffled. I tried the 100k resistor with pin 8 but the buzz is the same.

With a 1uf capacitor on IC15A pin 9 and ground, I have no buzz at all even with my mixing console my distortion pedal and X0x at full volume smile, so it defintely must be on 12V rail?

Many thanks again for your precious insight applause
guest
ok, so that means the noise is coming from the OTA stage and not the buffer, which is unexpected. its also odd that you got any sound at all out.

put pin6 back in and remove pin4, does it buzz? if yes, then remove pins1,2 and check.

its still worth having a look at the 12V trace near R127.
charkachak
I have sound with the 1uf capacitor, it did the trick quite well smile, that's why I suspected the 12V rail.

where is the OTA stage?
charkachak
Without pin 6, the buzz is gone but the sound is muffled. with another capacitor (1uF) I have sound and no more buzz. Do I still need to check Pin4 Pin 2 and Pin 1? I'll have a close look at the 12V rail near r127
guest
the BA6110 is composed of an OTA stage and a buffer. the OTA is on pins1,2,3,4,6 the buffer is on pins7,8 and pins5,9 are powersupply.

by 1uF capacitor, you mean a capacitor between the 12V and gnd near the BA6110? if that works, and youre happy with it, then put in a 10uF or bigger capacitor and call it done. it means there is still somehting not right either in the 12V rail or the VCO thats causing the issue. double check C32. make sure its solderd well (maybe replace it in case its badd), and check that the ground pin goes to ground with a multimeter. if thats all good, then there is something wonky in the VCO thats making the powersupply noisier than it should be.
charkachak
Oh that was C32 the culprit. Problem solved ! I replaced it and everything is working fine smile

I had replaced almost all the VCO components except Q25 Q26 and C32 before investigating in the other sections of the PCB.

I thank you so much for your help, it was nothing just a damned cap near the 12V rail (3 caps were nevertheless defective in my friend's build) but you taught me a lot of things with your great knowledge on the X0xb0x and I also thank you for that thumbs up

My friend will be super happy when I call him to tell him his X0x works perfectly now.
guest
im sorry to hear you had bad capacitors, that is not a common component to fail (at least on new builds), and therefore makes it harder to find. but im glad you found the issue and it works.
MUFF WIGGLER Forum Index -> Music Tech DIY Goto page 1, 2, 3  Next [all]
Page 1 of 3
Powered by phpBB © phpBB Group