MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Not sure if Disting MK3 microSD slot is broken
MUFF WIGGLER Forum Index -> Expert Sleepers  
Author Not sure if Disting MK3 microSD slot is broken
sutekina bipu-on
Hi everyone,

i recently got a used disting mk3 but i am not sure if the microSD slot is broken or not. I tried updating firmware and it seemed like it might have worked but i really can't tell. It was either on the latest or second to latest firmware when I got in the mail a couple days ago.

I am trying to see if i can get either the WAV player or MIDI player to play someting back just so i can see if everything works okay. Since this is my first Disting, i wanted to come here to ask someone with more experience to make sure i'm doing this right.


I have a 16 bit 44.1khz mono wav file on the root of the SD card called heke.wav. I also have a type 0 midi file called craymen.midi. So if i have this text file and set it to either playback or midi mode, it should just start going by itself?

playlist.txt wrote:
disting playlist v1
-loop=1
-gap=0
-fadeIn=0
-fadeOut=0
heke.wav


Can someone tell me if this is right? If i'm not mistaken, this should just loop the wav file indefinitely making it pretty simple to tell if the slot's broken or not?

If the slot is broken, i may try going on ebay to get one of those Arduino SD card adapters and solder it up to the little solder points next to the mk3's sd card slot.
os
It should be fairly clear whether the firmware update works - it should look like this:


Please attach the actual playlist file here.
sutekina bipu-on
os wrote:
It should be fairly clear whether the firmware update works - it should look like this:


Please attach the actual playlist file here.


Cool, thanks, it looked mostly like that though i don't remember if all the lights went flashing that fast. It went by pretty fast, but did end with bouncing between the A & B lights just like in your video.

I still haven't got the wav file playback working yet, so i assume i just have a bad playlist file?

Thanks so much for your help. Please see my playlist file attached.



My card slot still seems to work but it's definitely loose and on the verge of breaking off. If it does break off i will try soldering a full size sd card slot to it.
os
Possibly you just need a carriage return after the filename (as attached)?
sutekina bipu-on
os wrote:
Possibly you just need a carriage return after the filename (as attached)?


Thank you so much for your help. I tried with the playlist file you made me, but i'm afraid the sd slot might not be working. I read the instructions & watched the youtubes so i -think- i am attempting to get to Bank 2/a, but it's only letting me choose between bank 1 and bank 3 - otherwise indicating it doesn't notice a SD card inserted?

Thank you again for your help!


Here is the video i took (less than 30 secs long)
os
That LED behaviour indicates that it has detected an SD card. Otherwise it wouldn't be skipping some of the LEDs.
MUFF WIGGLER Forum Index -> Expert Sleepers  
Page 1 of 1
Powered by phpBB © phpBB Group