BEMI Easel Pitch Drifts When iProgram Card is Installed...

Discussing some incredible modules that don't quite fit into the other forum categories.

Moderators: luketeaford, lisa, Kent, Joe.

Post Reply
User avatar
analoglsd
Veteran Wiggler
Posts: 705
Joined: Thu Dec 10, 2009 6:15 pm
Location: Oakland, California
Contact:

BEMI Easel Pitch Drifts When iProgram Card is Installed...

Post by analoglsd » Thu Sep 26, 2019 1:46 am

My BEMI Easel pitch drift when the iProgram Card is installed. Is there a way to fix this?

-the drift happen whether or not the 218 is routed to pitch

User avatar
papz
Super Deluxe Wiggler
Posts: 3332
Joined: Sat May 18, 2013 6:52 pm
Location: in a suitcase
Contact:

Post by papz » Thu Sep 26, 2019 6:06 am

Your Easel likely has a weak PSU.
A PSU upgrade should help.
A DIY solution is shown in the VCS3 Card's build notes http://www.portabellabz.be/images/vcs3/ ... _notes.pdf
A powered 208 Hub has its own PSU for the cards http://www.portabellabz.be/hub.html
You can also ask BUSA for a replacement PSU board but it may take longer.
Finest EMS gear service and Music Easel/208 goodies

I'm not a synths dealer and I'm not aware of an inexpensive Synthi secret market, please don't ask me if I know one for sale.
I don't offer support of any kind to people attempting to build clones of EMS equipment.

User avatar
analoglsd
Veteran Wiggler
Posts: 705
Joined: Thu Dec 10, 2009 6:15 pm
Location: Oakland, California
Contact:

Post by analoglsd » Thu Sep 26, 2019 1:21 pm

Thank you so much papz!
Going to install the DIY fix that you've illustrated in the VCS3 Card build notes.
Cheers!

Post Reply

Return to “Buchla, EMS & Serge”