Using Group inserts as effects returns

Any music gear discussions that don't fit into one of the other forums.
Post Reply
nuromantix
Veteran Wiggler
Posts: 691
Joined: Sun Jul 29, 2012 7:34 am

Using Group inserts as effects returns

Post by nuromantix » Wed Oct 02, 2019 8:56 am

I have a Soundcraft Ghost which has 8 aux sends but only 4 stereo returns.

I am using 8 effects units, 1 on each aux send. The first four return to the FX returns but the other four have nowhere to go. I don't want to use up 8 of my channels if I can avoid it.

The Ghost also has 4 stereo groups that I don't use so I want to use the groups as effects returns. They have inserts on stereo jacks so I tried plugging the outputs from the effects units into those. This causes a bit of hum to appear on the master output even when the groups themselves are turned down/off.

Can anybody advise on wiring I need to do to avoid the hum? Probably there's some way to wire a cable with mono jacks at one end and stereo jacks in some configuration for the returns.

Also: I don't want to use insert cables because then I lose the flexibilty you get from having aux sends.

User avatar
mmp
Veteran Wiggler
Posts: 580
Joined: Thu Sep 17, 2009 8:32 pm
Location: Northeast USA

Post by mmp » Wed Oct 02, 2019 9:17 am

Use insert cables on the group insert connectors and only use the return jacks for the FX outputs.

nuromantix
Veteran Wiggler
Posts: 691
Joined: Sun Jul 29, 2012 7:34 am

Post by nuromantix » Wed Oct 02, 2019 9:56 am

Thanks for the suggestion but it still hums!

nuromantix
Veteran Wiggler
Posts: 691
Joined: Sun Jul 29, 2012 7:34 am

Post by nuromantix » Wed Oct 09, 2019 5:50 pm

I had to lift a few grounds, all quiet now :)

Post Reply

Return to “General Gear”