Ableton Live latency in audio recordings [thread split]

Discussion and support for Expert Sleepers' Silent Way software and hardware.

Moderators: Kent, os

Post Reply
skweeegor
I can't believe I ate the whole thing
Posts: 502
Joined: Fri Feb 19, 2010 2:03 pm
Location: Ottawa

Post by skweeegor » Tue Nov 02, 2010 9:54 am

No problem. And, yeah +/-4.55v is pretty good. I doubt you'll miss the half volt.

I have issues with latency in live but not just with the ES-1, but absolutely everything. I have to manually adjust every track I record when I'm done, modular or not. Does this happen with your other synths, too?

If I remember correctly, even if you set up delay compensation in live, I believe it will only work if you have monitoring off on the track you're recording - meaning you need to have it hooked up to a mixer to hear what you're doing. If the track is set to Auto or In, Live won't adjust the latency and you'll have to do it manually.

This is what the manual says anyway, I haven't had a chance to test it yet.

User avatar
os
Super Deluxe Wiggler
Posts: 13646
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Tue Nov 02, 2010 10:10 am

It doesn't say that at all. It says
If you are recording into Live with monitoring set to "Off," you may want to make the Audio Preferences’ Overall Latency adjustment, which is described in the built-in program tutorial on setting up the Audio Preferences.
Live's behaviour with respect to latency should be the same whichever monitoring mode you have selected.

Sounds like you might need to play with the "Driver Error Compensation" setting in the Live prefs.

User avatar
os
Super Deluxe Wiggler
Posts: 13646
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Tue Nov 02, 2010 10:16 am

Live's built-in lesson on "Driver Error Compensation" makes all this fairly clear.

User avatar
JP
Ultra Wiggler
Posts: 928
Joined: Thu Jan 07, 2010 5:07 pm
Location: NJ

Post by JP » Tue Nov 02, 2010 10:24 am

SPent hours last night trying to adjust the audio latency settings and nothing changed, only way I could get latency down was to drop the "samples" section in the pref down to like 140, then it was almost spot on, but it also sounded clunky as hell.

I also tried popping an external midi instrument control into the midi track that fed the SW tracks, and set the external as the SW track, since with midi you can try to counter latency (I'm assuming live just fires the midi early) I figured that might be a way round the issue.

Didn't work either.

I know it's not really silent way specific, I just need to work round my audio latency issues, I fear I'll be adjusting every track I record manually though.

User avatar
os
Super Deluxe Wiggler
Posts: 13646
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Tue Nov 02, 2010 10:27 am

Changing the audio buffer sizes won't affect latency, only performance.

The only thing that will adjust latency is the Driver Error Compensation. Work through the Live tutorial with that name.

skweeegor
I can't believe I ate the whole thing
Posts: 502
Joined: Fri Feb 19, 2010 2:03 pm
Location: Ottawa

Post by skweeegor » Tue Nov 02, 2010 12:13 pm

I went through the tutorial for driver error compensation. Live only uses the compensation value when I have monitoring set to off. If it's on auto or in, it doesn't have any effect.

User avatar
os
Super Deluxe Wiggler
Posts: 13646
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Tue Nov 02, 2010 12:21 pm

You're right, you know:
http://forum.ableton.com/viewtopic.php? ... 7#p1179087

(is there an emoticon for humble pie?)

skweeegor
I can't believe I ate the whole thing
Posts: 502
Joined: Fri Feb 19, 2010 2:03 pm
Location: Ottawa

Post by skweeegor » Tue Nov 02, 2010 12:32 pm

Well, it's good to have a definitive answer now. The manual wasn't particularly clear on the issue, and if you hadn't made that post I probably would have put off checking it for another week. :lol:

Glad to have finally figured it out. :tu:

User avatar
JP
Ultra Wiggler
Posts: 928
Joined: Thu Jan 07, 2010 5:07 pm
Location: NJ

Post by JP » Tue Nov 02, 2010 12:50 pm

skweeegor wrote:I went through the tutorial for driver error compensation. Live only uses the compensation value when I have monitoring set to off. If it's on auto or in, it doesn't have any effect.
But then how do you hear it? That might be a really stupid question.

But if I have 2 tracks of midi drums, and my synth being triggered by midi thru SW, if I turn monitor off, I can't hear the synth audio in.

skweeegor
I can't believe I ate the whole thing
Posts: 502
Joined: Fri Feb 19, 2010 2:03 pm
Location: Ottawa

Post by skweeegor » Tue Nov 02, 2010 12:54 pm

The ideal way to do it would be to run your synths through a mixer first, that way you can monitor through there. If your synth has a headphone jack that could work but then you're limited to one thing at a time.

It kind of makes sense that it does it this way because if you were for example playing guitar to a drum track while monitoring through live, you would automatically adjust your playing to compensate for any latency, so for everything to line up properly, live records the track exactly as you are hearing it. Would be nice to have a setting where it compensates even with monitoring on, though.

skweeegor
I can't believe I ate the whole thing
Posts: 502
Joined: Fri Feb 19, 2010 2:03 pm
Location: Ottawa

Post by skweeegor » Tue Nov 02, 2010 12:58 pm

btw, I'm also finding midi latency plays a role here. When I did the compensation tutorial, live automatically adjusted the track properly without changing the driver error compensation, but when I'm recording external synths using Live's midi clock, I have to bump up the compensation by 10ms or so. Strangely enough, it's different among all my synths too - some seem to be behind more than others and I don't have any midi thru chaining going on.

User avatar
os
Super Deluxe Wiggler
Posts: 13646
Joined: Tue Jun 30, 2009 6:55 am
Location: UK
Contact:

Post by os » Tue Nov 02, 2010 2:52 pm

Once you involve external MIDI, all bets are off as regards timing and consistency of timing.
JP wrote:But then how do you hear it? That might be a really stupid question.

But if I have 2 tracks of midi drums, and my synth being triggered by midi thru SW, if I turn monitor off, I can't hear the synth audio in.
Maybe it works if you record on the channel with the monitoring set to 'off', but have another channel from the same input with the monitoring set to 'on'. Worth a go.

skweeegor
I can't believe I ate the whole thing
Posts: 502
Joined: Fri Feb 19, 2010 2:03 pm
Location: Ottawa

Post by skweeegor » Wed Nov 03, 2010 11:44 am

Good idea, os! Just tried that and it works perfectly. I wasn't looking forward to rerouting everything through my mixer.

User avatar
JP
Ultra Wiggler
Posts: 928
Joined: Thu Jan 07, 2010 5:07 pm
Location: NJ

Post by JP » Wed Nov 03, 2010 12:04 pm

I wonder if you can set another channel to get it's audio from teh first channel and then set monitor to on.

That would be crazy.

I'll try later tonight.

skweeegor
I can't believe I ate the whole thing
Posts: 502
Joined: Fri Feb 19, 2010 2:03 pm
Location: Ottawa

Post by skweeegor » Wed Nov 03, 2010 4:31 pm

Just tried that and it works too but is there something I'm missing about wanting to use that method? If anything, it adds an extra step because you'd have to re-route the track you're recording to the Master channel once you're done monitoring.

Post Reply

Return to “Expert Sleepers”