MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

My rig just died
MUFF WIGGLER Forum Index -> Eurorack Modules  
Author My rig just died
sgnhh
Pretty sure it's the PSU. Was working one second then the next my case won't turn on. Anyone know a good way to troubleshoot the PSU?
sandyb
feel free to slap me if this is *too* obvious but you have checked the fuse to see if it's that?
consumed
you can use your DMM to check your output voltages on the psu, each rail at a time, against ground. oh yeah, and check your fuse
Coffee Addiction FTW
sgnhh
I haven't even opened it up yet, so I haven't checked the fuse. Will be the first thing I do, though. I immediately got frustrated with it and decided to start up a game of Left 4 Dead instead of messing with it.
consumed
sgnhh wrote:
and decided to start up a game of Left 4 Dead instead


thats funny. im going to fire up l4d later. need a teammate?
steam: loopcycle
modularplanner
Is it a doepfer suitcase by any chance ? if so check the fuse next to the power inlet. Mine blew shortly after getting it and i crapped myself thinking i'd plugged something in the wrong way.
sgnhh
consumed: friended.

modularplanner: it's a Doepfer rack case, so I will look there. Thanks.
Soy Sos
Yeah, the fuse in the Doepfer case I had was really hard to get at.
Not sure why it was designed that way................... meh
VanEck
You guys playing L4D on steam?

Feel free to add me: VanEck
sgnhh
Added you.

and cheers guys, it was a blown fuse.
MUFF WIGGLER Forum Index -> Eurorack Modules  
Page 1 of 1
Powered by phpBB © phpBB Group