MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

LFO Mod - Range Selection Switch
MUFF WIGGLER Forum Index -> Fractional Rack Modules  
Author LFO Mod - Range Selection Switch
Muff Wiggler
The Blacet LFO includes a DIP package on the PCB to select from two different LFO ranges. I find it's useful to replace this with a panel-mounted switch.

carefully clip the four leads from the DIP package to remove it, and solder the contact to a SPDT switch.
Muff Wiggler
ok, took some pics to make it easier.

Step 1: Take the module out of your rack, and remove the power connector. Next, remove the faceplate (very very easy with this module), and drill a hole to mount your switch. Mount a SPDT switch in the hole, and make a fancy label if you want.



Step 2: Remove the DIP package from the PCB. Carefully cut the leads if you want, or desolder for a clean job. You'll be left with four pads. Hookup wire to the three of them shown in the picture, and connect each wire to the correct post of your SPST switch (also shown in the pic - note the snazzy color-coded wires for you).




Take out your multimeter and check continuity between both sides of the PCB and your new wires, as well as between the solder pad at the reverse side of the PCB and the corresponding lug on the SPDT switch.


You are done - enjoy.
Kwote
damn simple.

i'm gonna hook up a buncha tools on friday from mouser. i'm afraid i don't have a drill though. might have to hold out. i do have a power screw but not to confident about using that even with a proper drill tip. it's kinda cheap. not to mention i don't have a proper place to keep the faceplate in place. no vice or anything.

going with FPE for now on faceplates. but dang these mods seem like nothing when i get a visual. guess i need verbal & visual to really understand it all.

probably just my lack of build experience talking.
Muff Wiggler
this faceplate comes off (and goes back on) *REALLY* easily, because it is all PCB-mount pots and jacks. Totally worth removing, only takes about 1 minute.

Modules with 'flying wire' jacks, like the VCO and most of the other 2U-wide modules will be harder to take the faceplate off, because of all the jumble of jacks-on-wires you will end up with (and don't lose track of which jack is which!). I've always done the risky thing and drilled those without removing the panel. Patience is good though.

The panels drill very easily - I don't have a vice either, I've only ever used a hand to hold the module down while I drilled it, just holding the faceplate down on a piece of wood. I do recommend a drill though, don't do it with a power driver.

PLEASE NOTE -

A *VERY* important piece of advice for drilling panels - *ALWAYS* start with the smallest possible drillbit you have, and make a pilot hole. Then work your way up to the right size by using larger and larger drillbits. Far easier to control and less messy and more accurate this way. TRUST ME.
Kwote
solid. again me being lame for not having drilling experience. but yeah i plan to invest in a proper drill just can't right now. i would NEVER EVER use the power screw.

i think i was dumb to buy that power screw anyways. i bought it based on the tip to pretap the frac rack before screwing in modules. than come to find recently from plord you can pretap with a regular screwdriver like it's nuthin.

i was all in a rush. didn't research the screwdriver properly or anything. i could've got a solid drill with screwdriving capabilities if i just put some thought and time into it.

can i blame it on the ignorance of youth?? well i'm not 80 yet so i'm going with affirmative.
Muff Wiggler
bah, blame it on 'you gotta start somewehre and we were all there at one point anyway' wink
Kwote
Muff Wiggler wrote:
bah, blame it on 'you gotta start somewehre and we were all there at one point anyway' wink


i don't know man. i think ignorance of youth sounds cooler though. helps feed into the illusion that age actually matters. grin
plord
What? Man, drilling is tedious. I use one of these: http://www.aircraftspruce.com/catalog/topages/roperwhitney2.php

Makes a perfect hole every time. I've punched 2mm panels with only a little effort. It's not going to reach to the middle of a triple-Blacet sized panel, but that's about the only thing wrong with it.
Kwote
plord wrote:
What? Man, drilling is tedious. I use one of these: http://www.aircraftspruce.com/catalog/topages/roperwhitney2.php

Makes a perfect hole every time. I've punched 2mm panels with only a little effort. It's not going to reach to the middle of a triple-Blacet sized panel, but that's about the only thing wrong with it.


nice. that's what you used on the rack ears huh.

so did you just get the metal punch or did you get the punch bench mount base too?
plord
Kwote wrote:
nice. that's what you used on the rack ears huh.

so did you just get the metal punch or did you get the punch bench mount base too?


I didn't get the base, and sometimes I wish I did. I find myself putting all of my weight on the handle sometimes, and I think the base would make it easier to protect my hands smile
Kwote
awesome. linked and archived. i'm gonna pull the trigger on a big mouser tool order tonight. i'll see where the punch will fit into my budget after that.
scozbor
Muff Wiggler wrote:


Step 1: Take the module out of your rack, and remove the power connector. Next, remove the faceplate (very very easy with this module), and drill a hole to mount your switch. Mount a SPDT switch in the hole, and make a fancy label if you want.





Muff how did you make that little range label??^^^^^^^
Is it a decal?
Muff Wiggler
yep labels, done with a Brother P-Touch machine. It can do three different font sizes that are all pretty good on Blacet modules - this is the smallest one.
Cat-A-Tonic
So I did this mod to my (kit built) Micro LFO. It's great!
...but the LED only flashes when I flip the switch...
other than that it works perfectly.
Does anyone have any ideas what could be the issue here?

Here's a (somewhat redundant) pic of the front panel.
Randaleem
plord wrote:
What? Man, drilling is tedious. I use one of these: Makes a perfect hole every time. I've punched 2mm panels with only a little effort.

Hi, I use a roper-whitney punch too. They are the top-of-the-line in this kind of punch. You don't need the base, IMO. But, unless you're going to be making thousands of holes, the Harbor Freight clone of this tool is more than adequate. I have a few of these too, and there is little or no difference in their use compared to the R/W. But they only cost about twenty bucks!

For larger holes in Sheet metal, use a step drill, also known as a unibit. Looks like an industrial modern mini-christmas tree sculpture. Again there are high end (Greenlee) and lower cost versions of this tool, And again the Harbor Freight version works fine (3 pc. set under 10 bucks AIRC). www.harborfreight.com

I DO like top notch tools and supporting American MFRs. But it might not make sense to pay as much for a seldom used tool as you would for a module!

If you dont have a vise, simply take a block of 2x4 or other board, and screw two drywall or sheetmetal screws into it. Now twist the panel CW so its rotation is stopped by the screws, and the screwheads keep the panel from lifting. Now it can't spin or lift. This is as safe as using a vise! (as long as the board is long/big enough) If you're worried about scratching the panel, a few layers of masking tape solves that. Don't leave it on for a long time.

Kind regards, Randal
Exuviae
Cat-A-Tonic wrote:
So I did this mod to my (kit built) Micro LFO. It's great!
...but the LED only flashes when I flip the switch...
other than that it works perfectly.
Does anyone have any ideas what could be the issue here?

Here's a (somewhat redundant) pic of the front panel.


Um, yep. I just did this same mod and have the same result. No LED action unless the switch gets hit and it only lights for a second.

Anybody know why it happens or how to remedy this?

Brooks
Muff Wiggler
my modded microLFOs do not have that LED problem - the LED works fine in both positions of the range switch.

very odd, in particular that you both have this problem.

I guess, make sure you didn't acidentally short something out?
Babaluma
i remember when physically moving the jumpers (there are two right?) that one "undocumented" position resulted in some very weird led and lfo behaviour. maybe you are switching that mode in by mistake? just a thought.
panda30y
Off topic, but i'm just glad to see so much activity in the frac sub forum. Most days it's barely alive compared to a forum with excited eurorack users getting new toys or angry eurorack users unhappy. hyper
Exuviae
Hmmm...I don't believe anything is shorted out. What I do question is, according to the picture that I followed, there is a 4th pad left open by removing the DIP, which has nothing soldered to it when doing this mod. Seems that all 4 should be wired to something.

.b
Cat-A-Tonic
Exuviae wrote:
Hmmm...I don't believe anything is shorted out. What I do question is, according to the picture that I followed, there is a 4th pad left open by removing the DIP, which has nothing soldered to it when doing this mod. Seems that all 4 should be wired to something.

.b

exactly, but I couldn't figure what it the 4th pad should be soldered to either as I just did what Muff's pic showed.

As far as I can tell, the module works perfectly aside from the LED only flashing when the switch is flipped.

...at least I'm not the only one... seriously, i just don't get it

Perhaps it's time to ask John Blacet.
Exuviae
One step ahead of you, Cat-A-Tonic -here's the reponse I just got from The Man himself:

"Should not effect the LED unless perhaps some metal filings from drilling the hole have shorted out the LED."

Sadly, this doesn't help me as I have not yet drilled a hole to mount the switch - I didn't want to do that until I knew the mod was cool. This bums me out, but is totally the way my luck works. meh

My switch is just "floating" right now, but not touching anything -shouldn't be shorting anything.

Brooks
Cat-A-Tonic
Exuviae sussed out the problem. we're not worthy props.
The LED was wired backwards. d'oh!
Now my first Micro LFO (from a kit) is modded and working 100%! Mr. Green
AND I've got a second Micro LFO (factory built) to mod to as well! screaming goo yo
This a fantastic LFO by the way, and the rate switch mod is very worth while.
MUFF WIGGLER Forum Index -> Fractional Rack Modules  
Page 1 of 1
Powered by phpBB © phpBB Group