MUFF WIGGLER Forum Index
 FAQ & Terms of UseFAQ & Terms Of Use   Wiggler RadioMW Radio   Muff Wiggler TwitterTwitter   Support the site @ PatreonPatreon 
 SearchSearch   RegisterSign up   Log inLog in 
WIGGLING 'LITE' IN GUEST MODE

Tenori-On MIDI issues
MUFF WIGGLER Forum Index -> Tenori-On  
Author Tenori-On MIDI issues
Paranormal Patroler
Inspired by the MIDI tutorial videos of flx here is a thread to post any MIDI related issues that you have encountered with the TO that are noteworthy.

The hardware version outputs quite a lot more than just MIDI Note On information; usually the Sysex coming along or before the Note On is of the Real Time type. It has overloaded at least one of my MIDI receivers so I tend to use a MIDI filter if I want to plug into something which can't handle the load (sic). It doesn't happen often though, just one device out of many, but I think it would be worthwhile to compile a list of instruments that can't handle the MIDI stream without a filter. I'll add to the OP as additions come.


FILTER'S LIST

� Anyware Tinysizer's MIDI-CV Interface
� Gotharman's Note Randomizer mkII
� Moog Slim Phatty
� LeStrum
flx
Thanks for the thread!

I experienced crashes/glitches with the following two:
- Anyware Tinysizer's MIDI-CV Interface (crash)
- Moog Slim Phatty (glitches when using the TNR's L/R buttons)

My solutions:
- Doepfer Dark Link MIDI-CV Interface (successfully ignores TNR's SysEx)
- Roland A880 MIDI Patchbay (filters SysEx using a work-around)
Umcorps
Might be worth drilling down a bit more. The Tinysizer interface is actually the MCV876 hardware (http://m.bareille.free.fr/mcv876/mcv876.html) and its the v2.71 PIC16F876 firmware that is problem with TO.

As its a generic piece of kit it probably appears in other hardware devices. I know that its used in Digitana's interface for the VCS3/Synthi for example.
Paranormal Patroler
And it can't handle Sysex streams? That sounds kinda sucky.
Umcorps
I'm not entirely certain. I mean, it uses sysex to set itself up and there are other devices I've used with it that send sysex and haven't killed it. But the TO stops it dead in its tracks every time.

It's not like the TO is sending a massive stream of sysex. But it does send a message for just about every single action you make on it - press a button - sysex sent.

It's very weird because sysex, by definition, should just be ignored by any interface its not intended for. Thats what makes it exclusive. hihi So my best guess would be that a bug in the firmware fails to recognise the Yamaha sysex identifier correctly and tries to do something with it rather than just let it go. But I don't have any other Yamaha kit to test the theory out with.
Paranormal Patroler
Umcorps wrote:
It's not like the TO is sending a massive stream of sysex. But it does send a message for just about every single action you make on it - press a button - sysex sent.


Well Gotharman's Randomizer got confused and mistook Real Time sysex messages coming from the TO whenever you press any button (either control button or note) and translated it into a G1 or a C4. No reason. I've been using a filter in front of it ever since and problem solved.

Funnily enough it's not the TO at fault here.
Mr. Pete
have you been keeping your Slim Phatty updated with the Firmware that Moog releases? I've been using my Tenori-Ons (O&W) without any MIDI problems on all my modular AND moog gear ~Slim, Voyager, Tauris and Sub Phatty without Issue ~ I have kept the TO updated as well - keep meaning to use it to sequence other boards eg DX-7 and M-1 etc but have not got round to it

OTOH, have had my Kenton SOLO MIDI-CV make Logic freak when I use it to filter in a signal and then record the Outgoing MIDI ~ whether it's bringing in MIDI from Tenori-On or any MIDI source ~ MIDI/CV on the Telemetry seems to be a better bet because it doesn't try to pass much MIDI thru at all just notes, velocity and gate as far as I know


flx wrote:
Thanks for the thread!

I experienced crashes/glitches with the following two:
- Anyware Tinysizer's MIDI-CV Interface (crash)
- Moog Slim Phatty (glitches when using the TNR's L/R buttons)

My solutions:
- Doepfer Dark Link MIDI-CV Interface (successfully ignores TNR's SysEx)
- Roland A880 MIDI Patchbay (filters SysEx using a work-around)
Paranormal Patroler
Reading up on the MIDI spec I think it might be the Active Sensing that's probably messing things up. hmmm.....
Paranormal Patroler
Hello fellow wigglers,

if any of you has MIDI issues with the TO please check if filtering the following type of messages solves it.

F0 43 73 01 33 00 XX YY 00 F7
F0 43 73 01 33 00 08 XX YY F7
F0 43 73 01 33 00 09 XX YY F7

Where XX and YY are the MSN and LSN respectively.
widdly
New Tenori-on user here.

I've found that when the tenori goes into a screen saver mode (clock or song) it sends a program change message for every channel.

It should be possible to use this feature to configure an external module's programs by using "SaveAs Time Signal" in the Interior menu then manually running "Interior Start".
Paranormal Patroler
That's very interesting! Have you tried it?
widdly
Haven't tried it s just a theory. The pc messages were screwing up my k2000 settings when the screensaver started.
MUFF WIGGLER Forum Index -> Tenori-On  
Page 1 of 1
Powered by phpBB © phpBB Group